Gnome shell extensions (扩展)介绍

GNOME shell 扩展是什么?
GnomeShell扩展是官方为增强GNOME Shell 功能所设置的。今天有网友“一加一等于生”提醒gnome的扩展网站已经发布alpha了,让我介绍一下。GnomeShell扩展的确非常方便,可以直接点击网站上的扩展来增强GNOME功能。

gnome-shell extensions

gnome-shell extensions

安装Gnome-shell扩展的前提条件?
必须升级你的桌面到GnomeShell 3.2及以上版本才可以使用,如果你是3.0的版本建议经行升级,还有如果你是Unity桌面也不敢保证你能使用扩展。我用最新的ubuntu 12.04 beta1打开了扩展网站试了一下得到的提示是(看来不支持unity桌面):

gnomeshellextensions-unity

gnomeshellextensions-unity

在Gnome 3.2以上版本就没有该提示了:

gnomeshell 3.2extensions

gnomeshell 3.2extensions


gnome Shell用户,使用“系统设置”里面“系统信息”面板查询你的GNOME版本。
除了桌面版本之外,还有你的浏览器还必须是火狐,也不知道像Google浏览器这样基于WebKit的浏览器有没有问题。

如何卸载Gnomeshell扩展?
在GNOME 3.2中因为一些错误,会导致一些扩展无法正常​​卸载。 GNOME Shell 3.2.2.1已修复这些问题。如果你的卸载有问题,可升级gnomeshell到最新版本。
如果你的确无法进行升级,那就手动删除扩展,然后重启gnomeshell桌面,扩展安装目录~/.local/share/gnome-shell/extensions,找到你安装的扩展进行删除,然后ALT + F2 输入重启(restart)命令可完全删除。

如何更新扩展?
gnome 3.4之前的版本要更新必须删除之前的版本,重新安装,gnome官网上说的是gnome 3.4的版本会更加完善,之后就可直接升级。

gnome shell 扩展不支持Unity桌面,在Unity桌面下,Gnome shell扩展网站显示的信息:

ubuntuunitygnomeshellextensions

ubuntuunitygnomeshellextensions



为您推荐

说点什么

8 评论 在 "Gnome shell extensions (扩展)介绍"

提醒
avatar
排序:   最新 | 最旧 | 得票最多
cxbii
成员

安装扩展还需要前提条件?
必须升级你的桌面到GnomeShell 3.2及以上版本才可以使用,如果你是3.0的版本建议经行升级,还有如果你是Unity桌面也不敢保证你能使用改扩展。

这里是不是要检查下?
还有这个网站怎么这么久了还没正式开放。。。无语了

chinacnd
游客

的却需要3.2或更高版本才能支持

cxbii
成员

站长你链接错了,我想说的是貌似这句话是病句.你看下面这里
还有如果你是Unity桌面也不敢保证你能使用改扩展。
改拓展?这个是正确的?还是该拓展?

imcn
游客

的却错了,多谢指正

一加一等于生
游客

站长效率好高啊!!!
用Chromium(17.0.963.56 (Developer Build 121963 Linux) Ubuntu 12.04)试了一下,目前还没发现问题。
谢谢站长!

chinacnd
游客

不谢,相互学习中!

blackjay0419
游客

這篇文章似乎有些誤解 gnome shell extension當然不支援unity 因為unity 雖然用了gnome 3 但是在使用介面替換了gnome shell. 我用12.04 beta 板 另外在軟體中心裝了gnome shell 後 並沒有所謂的安裝前提的問題。
另外這個網站已經公開好幾個月了

wpDiscuz