Docker 1.0.1已经可以在Ubuntu 14.04 LTS上测试了!

Docker1.0.1已经正式登陆“trusty-proposed的归档文件”中,我们期望SRU在长期可支持版上得到更快的更新!我们非常渴望能得到大家的测试反馈,以确保那些从Docker0.9.1升级后的,和那些新安装的Docker1.0.1能够得到更好的表现,并且在Ubuntu’s LTS上也能够达到你所期望的最好效果!请将任何bug和问题提交到这里

u=3991667311,1896150789&fm=23&gp=0

此外,这个新版本的Docker软件包现在要安装到 /usr/bin/docker下面,而不是在以前版本的安装目录 /usr/bin/docker.io。这应该有助于 Ubuntu Docker软件包更紧密匹配我们伙伴向上游提供的文档示例

这里,超级感谢Paul Tagliamonte, James Page, Nick Stinemates, Tianon GraviRyan Harper ,正是他们向上贡献到了debianubuntu,才能在Trusty上得到软件包的更新。还有一点要说的是,我们正在针对在20141023日发布的Ubuntu 14.10 (Utopic)开发Docker 1.1.2 (也有可能是1.2.0)

下面是一些命令,可能会帮助到你做测试……

#检查候选版本是可用的#

$ sudo apt-get update

$ apt-cache show docker.io | grep ^Version:

如果显示0.9.1dfsg1-2(因为有必要),那么你需要使trusty-proposed容器是可用状态。

$ echo "deb http://archive.ubuntu.com/ubuntu/ trusty-proposed universe" | sudo tee -a /etc/apt/sources.list

$ sudo apt-get update

$ apt-cache show docker.io | grep ^Version:

现在你应该可以看到新的版本,1.0.1~dfsg1-0ubuntu1~ubuntu0.14.04.1,可用 (大概除了 1.0.1~dfsg1-0ubuntu1~ubuntu0.14.04.1)。

#升级#

检查你是否已经把Docker安装了,使用:

$ dpkg -l docker.io

如果这样的话,可以做个简单的升级:

$ sudo apt-get upgrade

现在,你可以检查你的Docker版本了:

$ sudo dpkg -l docker.io | grep -m1 ^ii | awk '{print $3}'

0.9.1~dfsg1-2

#新装#

你仅需要安装新软件包 ,使用:

$ sudo apt-get install docker.io

确保你使用的是最新的版本:

$ dpkg -l docker.io | grep -m1 ^ii | awk '{print $3}'

1.0.1~dfsg1-0ubuntu1~ubuntu0.14.04.1

#运行Docker#

如果你已经是一个Docker的用户,那你可能就不需要这些说明了;如果不是,还是要读一下本文,第一次尝试一下Docker,这是最简短的“快速开始指南” 。

$ sudo docker pull ubuntu

$ sudo docker run -i -t ubuntu /bin/bash

现在你正在在Ubuntu Docker容器内运行一个bash shell,仅仅一个bash哦~

root@1728ffd1d47b:/# ps -ef

UID PID PPID C STIME TTY TIME CMD

root 1 0 0 13:42 ? 00:00:00 /bin/bash

root 8 1 0 13:43 ? 00:00:00 ps -ef

如果你想在Docker做一些更有趣的事情,那么,欢迎你加入我们!

Dustin

投稿作者 作者网站


为您推荐

说点什么

您将是第一位评论人!

提醒
avatar